A-A+

Seagate BlackArmor 400 NAS

2016年01月05日 学习小计 暂无评论 阅读 1 次

WARNING: Please note that this article was published a long time ago. The information contained might be outdated.

If you don't want to read the whole story to get the important stuff just read this:

  • Check the Seagate website for compatible hard drives
  • When inserting new hard disks in the BlackArmor 400 NAS always zero fill them first
  • Don't use Seagate's DiscWizard to zero fill drives but the dd command: dd if=/dev/zero of=/dev/disk_device bs=1M conv=noerror
  • When you buy new drives don't assume they are zero-filled or unpartitioned
  • Read this: How to prepare a Hard Disk whilst installed in a Synology NAS

The Story

The story begins about two years ago. Tired of having USB hard drives everywhere, I decided I needed a NAS to manage my backups. So after some googling around, I bought theSeagate BlackArmor 400. Along with it I bought 4 Western Digital Caviar Green hard disks.

Few days later the big package arrived. I made space on my desk at work and started mounting the drives in the NAS. Few minutes later I plugged the LAN and power adapter and the devices turned on. The small screen on the BlackArmor informed me of what was going on (downloading the OS and doing other stuff). A couple of hours later I had all working. I started copying some files and testing the speed. Then something happened. The four drives led started to become amber one at a time. All disks, one at a time, where failing. So I've called the vendor and they managed to pickup the broken drives and send me new ones. So I received four more Western Digital Caviar Green drives, but I wasn't luckier than the first time. Again, all four drives failed. This time the vendor gave me back the money for the drives and didn't sent me new ones. I had a Seagate BlackArmor 400 NAS without disks.

After a couple of years (few weeks ago), I came trough a forum where people were writing about problems with Western Digital Caviar Green drives when used with the Linux kernel. They were describing a problem related to the power management features of the drive or the way Linux handled this features. So I recalled the experience I had with the BlackArmor NAS and the Caviar Green drives and I decided to contact Seagate for help. Support was great and I was forwarded to a list of supported drives for my NAS. Meanwhile I found out that Seagate was giving 3 years of warranty on the BlackArmor 400 NAS, so my hardware was still covered by warranty. I decided to give the BlackArmor one more try. I bought four Seagate ST3000DM001 drives and hoped for the best.

Some days later the drives arrived. I mounted the drives in the NAS, connected the hardware to LAN and to electrical power. After two years of inactivity the Seagate BlackArmor booted as nothing ever happened. But the status LEDs of the four drives were all amber, not green. After a couple of minutes the LCD screen of the NAS was showing a warning message: "System Warning: HasForeignDsk(s)".

Frustrated I wrote Seagate calling for help and started searching on the Internet information about the problem. In a couple of articles I read that even new drives can't "just be used" in a NAS. The drives must be zero-filled first.

So I started looking for Seagate articles talking about zero-fill and the only info I could find explained how to use a software called DiscWizard and how to use it to zero fill a drive. DiscWizard is compatible only with Microsoft Windows. The article by Seagate has also a link to an article that talks about OS X, but the software used in the guide seems quite old. No article about any GNU/Linux distribution.

So I took a look at what was inside the hard disks and what I found was really disappointing: the drives had already 2 partitions, one of 750gb not accessible, one formatted with NTFS. I started searching for info on how to zero fill the drives using GNU/Linux and the best article I could find is one from Synology, which I can reassume in: dd if=/dev/zero of=/dev/disk_device bs=1M conv=noerror

Since the zero-filling process was going to take a lot of hours for each drive, I decided to use the Seagate application for one drive and dd for the other, planning to zero-fill two drives at the same time with two computers. I soon realized that the Seagate page describing how to use DiskWizard points to an old version of the software so I had to guess and search the Internet to find out how to use it. The computer using dd was much faster than the one using DiskWizard, so I zero-filled one drive with Seagate's application and the other tree with dd. When I inserted the 4 drives back again in the BalckArmor, the tree drives zero filled using dd had all green lighted LEDs, the one zero filled using DiscWizard had the amber LED lit. I must have guessed wrong using DiscWizard. So I removed the disk and used dd.

After hours of disk writing I finally inserted all four zero-filled drives in the BlackArmor NAS and all went smooth as the Synology guide describes.

google 搜索 system warning has Foreign disk 3tb nas400

给我留言

Copyright © 浩然东方 保留所有权利.   Theme  Ality 07032740

用户登录

测试聊天